Monument Peak Site outage
Postmortem

Generator or utility power came back online around 1430.

Posted Mar 01, 2023 - 14:36 PST

Resolved
The power at our Monument Peak tower site failed, and the generator failed to come online before our UPS ran out.

This affects customers off of Monument Peak, Superstition Mountain, and Toro Peak.
Posted Mar 01, 2023 - 14:00 PST